$re = '/(?<!\\\\)(?:\\\\\\\\)*\'([^\'\\\\]*(?:\\\\.[^\'\\\\]*)*)\'/';
$str = '[(u\'apple\',), (u\'banana\',)]
[(u\'apple\',), (u\'banana\',), (u\'abc\\\'def\',)]
\\\\\'abc\'\'def\'
\\\\\\\'abc \'abc\\\\\\\\\\\'def\'
|- CORRECT-|';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);