import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]+\\s?(heures?|h)([0-9]+)?";
final String string = "I should leave the house at 16h45 but I am late and I should not be arriving between 2 h or 3h or maybe 4heures\n\n\n"
+ "2h / 2h / 2 heure / 2heure / 2 heures / 2heures to #hour";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}