re = /[0-9]+\s?(heures?|h)([0-9]+)?/m
str = 'I should leave the house at 16h45 but I am late and I should not be arriving between 2 h or 3h or maybe 4heures
2h / 2h / 2 heure / 2heure / 2 heures / 2heures to #hour'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end