import re
regex = re.compile(r"[0-9]+\s?(heures?|h)([0-9]+)?", flags=re.MULTILINE)
test_str = ("I should leave the house at 16h45 but I am late and I should not be arriving between 2 h or 3h or maybe 4heures\n\n\n"
"2h / 2h / 2 heure / 2heure / 2 heures / 2heures to #hour")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")