package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[062]{1,3}`)
var str = `085362009557
6285362009557
62085362009557
06285362009557
85362009557
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}