$re = '/^[062]{1,3}/m';
$str = '085362009557
6285362009557
62085362009557
06285362009557
85362009557
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);