re = /^[062]{1,3}/m
str = '085362009557
6285362009557
62085362009557
06285362009557
85362009557
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end