using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:“[^“”]+”|""[^""]+""|(?<=,|^)[^“”,""]+(?=(?:,|$)))";
string input = @"sunil,""foo, bar"",""abc,xyz"",anil tiwari,""akhilesh,sun"", ""first,second,third"", ""test"", “this is a test”,word
400,test,""don't split, this"",15";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}