re = /(?:“[^“”]+”|"[^"]+"|(?<=,|^)[^“”,"]+(?=(?:,|$)))/m
str = 'sunil,"foo, bar","abc,xyz",anil tiwari,"akhilesh,sun", "first,second,third", "test", “this is a test”,word
400,test,"don\'t split, this",15'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end