$re = '/(?:“[^“”]+”|"[^"]+"|(?<=,|^)[^“”,"]+(?=(?:,|$)))/m';
$str = 'sunil,"foo, bar","abc,xyz",anil tiwari,"akhilesh,sun", "first,second,third", "test", “this is a test”,word
400,test,"don\'t split, this",15';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);