re = /<strong>Производитель:<\/strong>([^<]+)/m
str = '<strong>Производитель:</strong> Italpollina (Италия)<strong>
<strong>Производитель:</strong> Italpollina (Италия)<br>
<strong>Производитель:</strong> Italpollina (Италия)</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end