import re
regex = re.compile(r"^(?:[a-zA-Z0-9]|\s\B){12}$", flags=re.MULTILINE)
test_str = ("abC123def456\n"
"abc123dEf45 \n"
"abc123def4 \n"
"sd45f45FFFRd\n\n"
" abc123def45\n"
"abc123 ef456\n"
"123\n"
"sd45f45FFFR")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")