re = /^(?:[a-zA-Z0-9]|\s\B){12}$/m
str = 'abC123def456
abc123dEf45
abc123def4
sd45f45FFFRd
abc123def45
abc123 ef456
123
sd45f45FFFR'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end