using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<text xml:lang="")en"">(.+?)(</text>)\R \1es"">\3\R \1fr"">\3\R \1de"">\3\R \1pt"">\3\R \1du"">\3";
string substitution = @"<en>\2</en>\r\n <es>\2</es>\r\n <fr>\2</fr>\r\n <de>\2</de>\r\n <pt>\2</pt>\r\n <du>\2</du>";
string input = @" <text xml:lang=""en"">""Insert Swab to Start Analysis""</text>
<text xml:lang=""es""></text>
<text xml:lang=""fr""></text>
<text xml:lang=""de""></text>
<text xml:lang=""pt""></text>
<text xml:lang=""du""></text>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}