# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<text xml:lang=\")en\">(.+?)(</text>)\R \1es\">\3\R \1fr\">\3\R \1de\">\3\R \1pt\">\3\R \1du\">\3"
test_str = (" <text xml:lang=\"en\">\"Insert Swab to Start Analysis\"</text>\n"
" <text xml:lang=\"es\"></text>\n"
" <text xml:lang=\"fr\"></text>\n"
" <text xml:lang=\"de\"></text>\n"
" <text xml:lang=\"pt\"></text>\n"
" <text xml:lang=\"du\"></text>")
subst = "<en>\\2</en>\\r\\n <es>\\2</es>\\r\\n <fr>\\2</fr>\\r\\n <de>\\2</de>\\r\\n <pt>\\2</pt>\\r\\n <du>\\2</du>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.