package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{1,}\:[0-5][0-9]`)
var str = `350:59
20:22
1:68
0:12
24:75`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}