$re = '/\d{1,}\:[0-5][0-9]/';
$str = '350:59
20:22
1:68
0:12
24:75';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);