import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!@)(www\\.|https?:\\/\\/)[a-z0-9-_]{2,254}\\.[a-z0-9]{2,4}(\\S*)";
final String string = "check out my facebook www.prop-ERty-bg.ru/11be check out my facebook\n"
+ "www.property-bg.ru/11be horsae@microsoft.com ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}