const regex = /(?<!@)(www\.|https?:\/\/)[a-z0-9-_]{2,254}\.[a-z0-9]{2,4}(\S*)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!@)(www\\.|https?:\\\/\\\/)[a-z0-9-_]{2,254}\\.[a-z0-9]{2,4}(\\S*)', 'gmi')
const str = `check out my facebook www.prop-ERty-bg.ru/11be check out my facebook
www.property-bg.ru/11be horsae@microsoft.com `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}