$re = '/(?<!@)(www\.|https?:\/\/)[a-z0-9-_]{2,254}\.[a-z0-9]{2,4}(\S*)/mi';
$str = 'check out my facebook www.prop-ERty-bg.ru/11be check out my facebook
www.property-bg.ru/11be horsae@microsoft.com ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);