using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=`)[^`\r\n]+(?=`)";
string input = @"This is `inline code` (obviously).
Here is a code fence:
```
Some code
blah blah
```
Another `example for you`.
another fence:
```json
{""title"":""Hello World!""}
```";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}