re = /(?<=`)[^`\r\n]+(?=`)/
str = 'This is `inline code` (obviously).
Here is a code fence:
```
Some code
blah blah
```
Another `example for you`.
another fence:
```json
{"title":"Hello World!"}
```'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end