$re = '/(?<=`)[^`\r\n]+(?=`)/';
$str = 'This is `inline code` (obviously).
Here is a code fence:
```
Some code
blah blah
```
Another `example for you`.
another fence:
```json
{"title":"Hello World!"}
```';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);