using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<!--(?:(?!-->|""hide"":).)*+""hide"":true\b(?:(?!-->).)*/-->(*SKIP)(*F)|<!--(?:(?!-->|""user"":).)*""user"":""\K[^""]+(?=""(?:(?!-->).)*-->)";
string input = @"<!-- block {""user"":""josh-hart"", 1234566 ,""hide"":false} /--><!-- block {""user"":""jalen-brunson"", 7744633 ,""hide"":true} /--><!-- block {""user"":""josh-hart"", 1234566 ,""hide"":false} /-->
<!-- block {""user"":""jalen-brunson"", 7744633 ,""hide"":true} /-->
<!-- block {""user"":""julius-randle"", 333333,""hide"":false} /-->
<!-- block {""user"":""obi-toppin"", 4hh3n33n33n, /-->
<!-- block {""user"":""rj-barrett"", nmremxxx!! ,""hide"":true} /-->
<!-- block {""user"":""mitch-robinson"",yahaoao /-->
<!-- block {""user"":""mitch-robinson"",yahaoao
hi there, do not remove this ""user"":""mitch-robinson""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}