# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<!--(?:(?!-->|\"hide\":).)*+\"hide\":true\b(?:(?!-->).)*/-->(*SKIP)(*F)|<!--(?:(?!-->|\"user\":).)*\"user\":\"\K[^\"]+(?=\"(?:(?!-->).)*-->)"
test_str = ("<!-- block {\"user\":\"josh-hart\", 1234566 ,\"hide\":false} /--><!-- block {\"user\":\"jalen-brunson\", 7744633 ,\"hide\":true} /--><!-- block {\"user\":\"josh-hart\", 1234566 ,\"hide\":false} /-->\n"
"<!-- block {\"user\":\"jalen-brunson\", 7744633 ,\"hide\":true} /-->\n"
"<!-- block {\"user\":\"julius-randle\", 333333,\"hide\":false} /-->\n"
"<!-- block {\"user\":\"obi-toppin\", 4hh3n33n33n, /-->\n"
"<!-- block {\"user\":\"rj-barrett\", nmremxxx!! ,\"hide\":true} /-->\n"
"<!-- block {\"user\":\"mitch-robinson\",yahaoao /-->\n\n"
"<!-- block {\"user\":\"mitch-robinson\",yahaoao\n"
"hi there, do not remove this \"user\":\"mitch-robinson\"\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.