import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<!--(?:(?!-->|\"hide\":).)*+\"hide\":true\\b(?:(?!-->).)*/-->(*SKIP)(*F)|<!--(?:(?!-->|\"user\":).)*\"user\":\"\\K[^\"]+(?=\"(?:(?!-->).)*-->)";
final String string = "<!-- block {\"user\":\"josh-hart\", 1234566 ,\"hide\":false} /--><!-- block {\"user\":\"jalen-brunson\", 7744633 ,\"hide\":true} /--><!-- block {\"user\":\"josh-hart\", 1234566 ,\"hide\":false} /-->\n"
+ "<!-- block {\"user\":\"jalen-brunson\", 7744633 ,\"hide\":true} /-->\n"
+ "<!-- block {\"user\":\"julius-randle\", 333333,\"hide\":false} /-->\n"
+ "<!-- block {\"user\":\"obi-toppin\", 4hh3n33n33n, /-->\n"
+ "<!-- block {\"user\":\"rj-barrett\", nmremxxx!! ,\"hide\":true} /-->\n"
+ "<!-- block {\"user\":\"mitch-robinson\",yahaoao /-->\n\n"
+ "<!-- block {\"user\":\"mitch-robinson\",yahaoao\n"
+ "hi there, do not remove this \"user\":\"mitch-robinson\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}