#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(https?|ftp):\/\/([a-zA-Z0-9.-]+(:[a-zA-Z0-9.&%$-]+)*@)*((25[0-5]|2[0-4][0-9]|1[0-9]{2}|[1-9][0-9]?)(\.(25[0-5]|2[0-4][0-9]|1[0-9]{2}|[1-9]?[0-9])){3}|([a-zA-Z0-9-]+\.)*[a-zA-Z0-9-]+\.(com|edu|gov|int|mil|net|org|biz|arpa|info|name|pro|aero|coop|museum|[a-zA-Z]{2}))(:[0-9]+)*(\/((\*$)|$|(https?:\/\/)?[\*a-zA-Z0-9.,?'\\+&%$#=~_-]+))*$"
Local $sString = "https://www.google.com.ua/search?q=account+site%3Atelegram.org" & @CRLF & _
"https://www.google.com.ua" & @CRLF & _
"https://cdn.lijit.com/www/delivery/fpi.js?z=198017&width=160&height=600" & @CRLF & _
"https://cdn.lijit.com/www/delivery/fpi.js?z=198017&width=160&height=600#display" & @CRLF & _
"http://web.archive.org/web/*/http://cdn.lijit.com/*" & @CRLF & _
"http://127.0.0.1:80" & @CRLF & _
"https://192.168.1.1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")