# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(https?|ftp):\/\/([a-zA-Z0-9.-]+(:[a-zA-Z0-9.&%$-]+)*@)*((25[0-5]|2[0-4][0-9]|1[0-9]{2}|[1-9][0-9]?)(\.(25[0-5]|2[0-4][0-9]|1[0-9]{2}|[1-9]?[0-9])){3}|([a-zA-Z0-9-]+\.)*[a-zA-Z0-9-]+\.(com|edu|gov|int|mil|net|org|biz|arpa|info|name|pro|aero|coop|museum|[a-zA-Z]{2}))(:[0-9]+)*(\/((\*$)|$|(https?:\/\/)?[\*a-zA-Z0-9.,?'\\+&%$#=~_-]+))*$"
test_str = ("https://www.google.com.ua/search?q=account+site%3Atelegram.org\n"
"https://www.google.com.ua\n"
"https://cdn.lijit.com/www/delivery/fpi.js?z=198017&width=160&height=600\n"
"https://cdn.lijit.com/www/delivery/fpi.js?z=198017&width=160&height=600#display\n"
"http://web.archive.org/web/*/http://cdn.lijit.com/*\n"
"http://127.0.0.1:80\n"
"https://192.168.1.1")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.