const regex = /^(https?|ftp):\/\/([a-zA-Z0-9.-]+(:[a-zA-Z0-9.&%$-]+)*@)*((25[0-5]|2[0-4][0-9]|1[0-9]{2}|[1-9][0-9]?)(\.(25[0-5]|2[0-4][0-9]|1[0-9]{2}|[1-9]?[0-9])){3}|([a-zA-Z0-9-]+\.)*[a-zA-Z0-9-]+\.(com|edu|gov|int|mil|net|org|biz|arpa|info|name|pro|aero|coop|museum|[a-zA-Z]{2}))(:[0-9]+)*(\/((\*$)|$|(https?:\/\/)?[\*a-zA-Z0-9.,?'\\+&%$#=~_-]+))*$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(https?|ftp):\\\/\\\/([a-zA-Z0-9.-]+(:[a-zA-Z0-9.&%$-]+)*@)*((25[0-5]|2[0-4][0-9]|1[0-9]{2}|[1-9][0-9]?)(\\.(25[0-5]|2[0-4][0-9]|1[0-9]{2}|[1-9]?[0-9])){3}|([a-zA-Z0-9-]+\\.)*[a-zA-Z0-9-]+\\.(com|edu|gov|int|mil|net|org|biz|arpa|info|name|pro|aero|coop|museum|[a-zA-Z]{2}))(:[0-9]+)*(\\\/((\\*$)|$|(https?:\\\/\\\/)?[\\*a-zA-Z0-9.,?\'\\\\+&%$#=~_-]+))*$', 'mg')
const str = `https://www.google.com.ua/search?q=account+site%3Atelegram.org
https://www.google.com.ua
https://cdn.lijit.com/www/delivery/fpi.js?z=198017&width=160&height=600
https://cdn.lijit.com/www/delivery/fpi.js?z=198017&width=160&height=600#display
http://web.archive.org/web/*/http://cdn.lijit.com/*
http://127.0.0.1:80
https://192.168.1.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}