#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)({(?>[^{}]|(?1))*})|"key":\s*"([^"]*?)""
Local $sString = " "b": { " & @CRLF & _
" "c": { " & @CRLF & _
" "d": "v1", " & @CRLF & _
" "key": "v2" " & @CRLF & _
" } " & @CRLF & _
" }, " & @CRLF & _
" "c": { " & @CRLF & _
" "g": "v3", " & @CRLF & _
" "key": "v4" " & @CRLF & _
" }, " & @CRLF & _
" "key": "v5" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")