using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"({(?>[^{}]|(?1))*})|""key"":\s*""([^""]*?)""";
string input = @" ""b"": {
""c"": {
""d"": ""v1"",
""key"": ""v2""
}
},
""c"": {
""g"": ""v3"",
""key"": ""v4""
},
""key"": ""v5"" ";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}