re = /({(?>[^{}]|(?1))*})|"key":\s*"([^"]*?)"/
str = ' "b": {
"c": {
"d": "v1",
"key": "v2"
}
},
"c": {
"g": "v3",
"key": "v4"
},
"key": "v5" '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end