#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-1][0-9]|2[0-3]|[0-9]):([0-5][0-9])$"
Local $sString = "23:59" & @CRLF & _
"17:32" & @CRLF & _
"98:54" & @CRLF & _
"123:5" & @CRLF & _
"1:1" & @CRLF & _
"1:11" & @CRLF & _
"11:1" & @CRLF & _
"12:05" & @CRLF & _
"07:00" & @CRLF & _
"00:60" & @CRLF & _
"13:170" & @CRLF & _
"120:54" & @CRLF & _
"00:00" & @CRLF & _
"12:0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")