// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([0-1][0-9]|2[0-3]|[0-9]):([0-5][0-9])$").unwrap();
let string = "23:59
17:32
98:54
123:5
1:1
1:11
11:1
12:05
07:00
00:60
13:170
120:54
00:00
12:0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}