use strict;
my $str = '23:59
17:32
98:54
123:5
1:1
1:11
11:1
12:05
07:00
00:60
13:170
120:54
00:00
12:0';
my $regex = qr/^([0-1][0-9]|2[0-3]|[0-9]):([0-5][0-9])$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}