$re = '/^([a-zA-Z0-9-_]+)_$/m';
$str = 'start_
some_anchor_
another-anchor_
`Document Title`_
Document Title_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);