re = /^([a-zA-Z0-9-_]+)_$/m
str = 'start_
some_anchor_
another-anchor_
`Document Title`_
Document Title_'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end