import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"(?<baseUrl>\\/([^\\/]+\\/)+)(?<guid>[^\\\"]+)\\\"";
final String string = "\"/dsa/api/playercommands/a6ada68b-7a72-4f38-b752-d99f7efd4cb8\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}