$re = '/\"(?<baseUrl>\/([^\/]+\/)+)(?<guid>[^\"]+)\"/';
$str = '"/dsa/api/playercommands/a6ada68b-7a72-4f38-b752-d99f7efd4cb8"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);