const regex = /^(.*):(\d+):(\d+):\s+(warning|error):\s+(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*):(\\d+):(\\d+):\\s+(warning|error):\\s+(.*)$', 'gm')
const str = `../include/typedefsandconsts.h:21:20: warning: ‘rootfolder’ defined but not used [-Wunused-variable]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}