re = /^(.*):(\d+):(\d+):\s+(warning|error):\s+(.*)$/m
str = '../include/typedefsandconsts.h:21:20: warning: ‘rootfolder’ defined but not used [-Wunused-variable]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end