$re = '/^(.*):(\d+):(\d+):\s+(warning|error):\s+(.*)$/m';
$str = '../include/typedefsandconsts.h:21:20: warning: ‘rootfolder’ defined but not used [-Wunused-variable]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);