#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\w*raw(?<!\[erai-)"
Local $sString = " [Erai-raws]" & @CRLF & _
" [New-raws]" & @CRLF & _
"Tsundere-Raws" & @CRLF & _
"erairaws" & @CRLF & _
"erairaw" & @CRLF & _
"erai-raw" & @CRLF & _
"erai-raws" & @CRLF & _
"naturalraw" & @CRLF & _
"rawnatural" & @CRLF & _
"[Erai-raws]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")