import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w*raw(?<!\\[erai-)";
final String string = " [Erai-raws]\n"
+ " [New-raws]\n"
+ "Tsundere-Raws\n"
+ "erairaws\n"
+ "erairaw\n"
+ "erai-raw\n"
+ "erai-raws\n"
+ "naturalraw\n"
+ "rawnatural\n"
+ "[Erai-raws]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}