$re = '/\w*raw(?<!\[erai-)/mi';
$str = ' [Erai-raws]
[New-raws]
Tsundere-Raws
erairaws
erairaw
erai-raw
erai-raws
naturalraw
rawnatural
[Erai-raws]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);