package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?m)^[^\r\n,]+`)
var str = `Brighton, United Kingdom
Singapore
Austin, TX, USA
San Francisco, CA, USA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}