$re = '/(?m)^[^\r\n,]+/m';
$str = 'Brighton, United Kingdom
Singapore
Austin, TX, USA
San Francisco, CA, USA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);