using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\bnot saying )(?<!\bnot saying that )(?<!\bnot that )(\b(?:you'?r?e?|u|op'?s?)) (\b(?:are|is))? ?(\ban?)? ?(\b(?:absolute|total))? ?(\bfuck(en|ing?))? ?(\binsult)";
string input = @"* OP is an absolute insult
* You are a insult
* You are a total fuckin insult
* not saying you are an insult";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}