re = /(?<!\bnot saying )(?<!\bnot saying that )(?<!\bnot that )(\b(?:you'?r?e?|u|op'?s?)) (\b(?:are|is))? ?(\ban?)? ?(\b(?:absolute|total))? ?(\bfuck(en|ing?))? ?(\binsult)/mi
str = '* OP is an absolute insult
* You are a insult
* You are a total fuckin insult
* not saying you are an insult'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end