const regex = /(?<!\bnot saying )(?<!\bnot saying that )(?<!\bnot that )(\b(?:you'?r?e?|u|op'?s?)) (\b(?:are|is))? ?(\ban?)? ?(\b(?:absolute|total))? ?(\bfuck(en|ing?))? ?(\binsult)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\bnot saying )(?<!\\bnot saying that )(?<!\\bnot that )(\\b(?:you\'?r?e?|u|op\'?s?)) (\\b(?:are|is))? ?(\\ban?)? ?(\\b(?:absolute|total))? ?(\\bfuck(en|ing?))? ?(\\binsult)', 'gmi')
const str = `* OP is an absolute insult
* You are a insult
* You are a total fuckin insult
* not saying you are an insult`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}